Funny, Google AdWords doesn’t know Firefox 7 is new

Ever since upgrading to FF7, I’ve been getting the following wording from Google AdWords:

We have detected that you are using an older web browser. For better performance with the AdWords interface, we recommend using a modern browser such as Firefox 3.5 or later, Chrome, Safari 4 or later, or Internet Explorer 8 or later. Learn more



Comments are closed.